Discuss problems you're having with your Tiko and the ways to solve them.
Announcements
Title Statistics Last post
 Software Update - 1.2.4 PLEASE UPDATE
by Customer_Support  - Mon Jan 09, 2017 9:45 pm
0 Replies 
7176 Views
by Customer_Support
Mon Jan 09, 2017 9:45 pm
 Recovery Page
by Customer_Support  - Fri Jan 06, 2017 7:49 pm
58 Replies 
5223 Views
by mariusstrom
Sun Jan 22, 2017 12:13 am
0 Replies 
53696 Views
by MadModder
Thu Sep 10, 2015 6:34 pm
Topics
Title Statistics Last post
 replacement suggestions
by Blue_Moon  - Wed May 24, 2017 2:28 am
0 Replies 
33 Views
by Blue_Moon
Wed May 24, 2017 2:28 am
 Bowden Tube Fix/Replacement. Suggestions?
by vladherrera  - Mon Mar 27, 2017 4:16 pm
2 Replies 
91 Views
by vladherrera
Tue May 23, 2017 4:38 pm
 Motor mount Clip Broke off..
by Duke878  - Sun Mar 12, 2017 3:37 am
17 Replies 
506 Views
by Duke878
Sun Apr 16, 2017 5:56 pm
 Layer shift mid print
by JohninOttawa  - Sat Apr 15, 2017 9:33 pm
1 Replies 
81 Views
by alfredjimenez
Sat Apr 15, 2017 10:20 pm
 Need a filament switch with connector
by Roming22  - Sat Apr 15, 2017 8:00 pm
0 Replies 
50 Views
by Roming22
Sat Apr 15, 2017 8:00 pm
 HAHAHAHAHHAHAHAHAHA Tiko, you kill me!
by FuShiLu  - Mon Mar 27, 2017 3:04 pm
2 Replies 
173 Views
by criton01
Sat Apr 15, 2017 6:07 pm
 Cura: no filament fed
by gisborne  - Thu Apr 13, 2017 1:57 pm
0 Replies 
72 Views
by gisborne
Thu Apr 13, 2017 1:57 pm
 Troubleshooting Error 203
by Kaeon  - Sun Jan 22, 2017 1:01 am
5 Replies 
364 Views
by Agier
Sat Apr 08, 2017 6:00 am
 Fixing my printer
by ripsir1983  - Sun Mar 12, 2017 9:26 pm
3 Replies 
217 Views
by ripsir1983
Thu Apr 06, 2017 7:27 pm
 Issue with filament
by wegvor  - Tue Apr 04, 2017 12:36 pm
0 Replies 
121 Views
by wegvor
Tue Apr 04, 2017 12:36 pm
 Loading issues
by 3dprinthings  - Sat Aug 13, 2016 3:14 pm
8 Replies 
1069 Views
by 3dtech
Sat Apr 01, 2017 6:54 am
 Wifi Password?
by eatonasher  - Fri Mar 31, 2017 7:00 pm
1 Replies 
109 Views
by Blue_Moon
Sat Apr 01, 2017 1:26 am
 Is auto calibration working for anyone?
by Jimustanguitar  - Thu Jul 21, 2016 12:34 pm
4 Replies 
786 Views
by Pratyeka
Thu Mar 30, 2017 11:31 pm
 3rd layer of Raft Ridges
by Rane  - Wed Mar 29, 2017 12:15 am
0 Replies 
77 Views
by Rane
Wed Mar 29, 2017 12:15 am
 Can't use gcode?
by ChristinB  - Mon Mar 27, 2017 10:10 pm
5 Replies 
258 Views
by FuShiLu
Tue Mar 28, 2017 9:03 pm
 Connecting to Home Network *Issues*
by Lincolnz  - Fri Mar 17, 2017 5:17 am
5 Replies 
231 Views
by ChristinB
Mon Mar 27, 2017 9:40 pm
 1.2.5 Update - Not Printing
by 48v  - Fri Jan 27, 2017 12:34 am
10 Replies 
558 Views
by Sniper
Mon Mar 27, 2017 3:44 pm
 Powering On and Nothing
by BlackBird246  - Thu Mar 23, 2017 11:58 pm
1 Replies 
92 Views
by Pratyeka
Fri Mar 24, 2017 10:59 am
4 Replies 
110 Views
by Lee G
Wed Mar 22, 2017 11:45 pm
 Raft misbehaviour
by JohninOttawa  - Wed Mar 15, 2017 8:35 pm
10 Replies 
331 Views
by Pratyeka
Sat Mar 18, 2017 7:40 pm
 Extreme, consistent, layer shifting
by Christopher Nickel  - Sun Dec 25, 2016 2:08 pm
40 Replies 
3119 Views
by CFong3d
Fri Mar 17, 2017 10:20 am
 When the nozzle heats, the printer shuts off
by macv36  - Sun Feb 12, 2017 10:20 am
5 Replies 
364 Views
by Pratyeka
Wed Mar 15, 2017 10:41 am
 Internal ID of holes are too small. . .
by Longshot  - Wed Mar 08, 2017 2:19 pm
5 Replies 
202 Views
by Pratyeka
Tue Mar 14, 2017 6:28 pm
 Inconsistent filament extrusion.
by SR16  - Sat Aug 27, 2016 6:16 pm
12 Replies 
1447 Views
by Pratyeka
Mon Mar 13, 2017 2:22 pm
 Stuck at Checking for filament
by Chrislink  - Thu Mar 09, 2017 5:11 pm
3 Replies 
171 Views
by xmodusterz
Sat Mar 11, 2017 1:55 pm
  • 1
  • 2
  • 3
  • 4
  • 5
  • 17