Discuss problems you're having with your Tiko and the ways to solve them.
Announcements
Title Statistics Last post
 Software Update - 1.2.4 PLEASE UPDATE
by Customer_Support  - Mon Jan 09, 2017 9:45 pm
0 Replies 
9281 Views
by Customer_Support
Mon Jan 09, 2017 9:45 pm
 Recovery Page
by Customer_Support  - Fri Jan 06, 2017 7:49 pm
65 Replies 
8699 Views
by JoeC
Tue Jun 13, 2017 12:47 am
0 Replies 
55705 Views
by MadModder
Thu Sep 10, 2015 6:34 pm
Topics
Title Statistics Last post
 Calibration failed, nozzle damaged bed
by 3dprinthings  - Wed Nov 23, 2016 10:01 pm
2 Replies 
539 Views
by UnasOne
Fri Nov 25, 2016 11:47 am
2 Replies 
324 Views
by Jimustanguitar
Tue Nov 22, 2016 8:10 pm
 Power wiring broke.
by SR16  - Fri Jul 29, 2016 7:15 pm
9 Replies 
1686 Views
by mike199
Sat Oct 22, 2016 12:31 pm
 Print Covered by Droplets
by yishi  - Sat Sep 17, 2016 3:08 pm
1 Replies 
848 Views
by LScott
Thu Oct 06, 2016 3:33 pm
 a part of the model missing
by cassius  - Mon Oct 03, 2016 8:05 am
1 Replies 
850 Views
by Customer_Support
Wed Oct 05, 2016 2:48 pm
1 Replies 
799 Views
by Customer_Support
Thu Sep 15, 2016 1:29 pm
 Self Destruct
by spencewesttx  - Thu Jul 28, 2016 1:08 pm
8 Replies 
1893 Views
by Customer_Support
Wed Sep 14, 2016 2:01 pm
 Filament stuck in the middle of the tube
by booker0108  - Sun Sep 04, 2016 5:39 pm
6 Replies 
1386 Views
by 3dtech
Wed Sep 14, 2016 5:42 am
 Nozzle dive, firmware bug?
by SR16  - Sat Aug 27, 2016 4:32 pm
2 Replies 
886 Views
by digitap
Wed Aug 31, 2016 4:45 pm
5 Replies 
1349 Views
by digitap
Wed Aug 31, 2016 4:37 pm
2 Replies 
682 Views
by Customer_Support
Wed Aug 31, 2016 3:48 pm
 Filament loading nightmare work around.
by SR16  - Tue Aug 30, 2016 4:35 pm
1 Replies 
937 Views
by Customer_Support
Wed Aug 31, 2016 3:46 pm
 Manual Calibration skill
by booker0108  - Mon Aug 29, 2016 8:35 pm
3 Replies 
854 Views
by SR16
Tue Aug 30, 2016 1:44 am
 Temperature issue solution??
by tbastian  - Fri Aug 19, 2016 2:55 pm
2 Replies 
742 Views
by csmith1510
Sun Aug 21, 2016 3:59 pm
1 Replies 
675 Views
by Customer_Support
Wed Aug 17, 2016 4:26 pm
 Failed to connect
by kcbchan88  - Sun Aug 07, 2016 8:18 am
1 Replies 
652 Views
by Customer_Support
Tue Aug 16, 2016 6:37 pm
 Getting prints to stick
by silby101  - Tue Aug 16, 2016 8:32 am
1 Replies 
712 Views
by Customer_Support
Tue Aug 16, 2016 2:24 pm
 Tiko-2A1D0-Error-04
by bekecs  - Sun Aug 07, 2016 7:09 am
3 Replies 
748 Views
by bekecs
Fri Aug 12, 2016 8:53 am
 Filament stuck on the entrance
by 01142  - Tue Aug 09, 2016 2:25 pm
3 Replies 
827 Views
by Customer_Support
Wed Aug 10, 2016 9:01 pm
 Won't update (error) from original firmware
by Fprint  - Wed Aug 10, 2016 1:02 pm
0 Replies 
442 Views
by Fprint
Wed Aug 10, 2016 1:02 pm
 tiko-0d550-Error-01
by kcbchan88  - Mon Aug 08, 2016 1:11 pm
1 Replies 
424 Views
by Rudy
Tue Aug 09, 2016 2:39 pm
 Filament stuck...
by Attilio  - Fri Jul 29, 2016 7:57 pm
5 Replies 
1182 Views
by robertjohnmorrison
Tue Aug 09, 2016 10:28 am
 Blob of goo
by jonkhill  - Mon Aug 08, 2016 8:58 am
1 Replies 
520 Views
by Customer_Support
Mon Aug 08, 2016 7:28 pm
5 Replies 
758 Views
by Rudy
Mon Aug 08, 2016 5:03 pm
 Tiko-9F61C-Error-04
by vigayim  - Sun Aug 07, 2016 3:29 pm
1 Replies 
460 Views
by Rudy
Mon Aug 08, 2016 5:03 pm
  • 1
  • 29
  • 30
  • 31
  • 32
  • 33